Billing preview in admin hub not showing all products for some customers

Incident Report for Jira Product Discovery

Resolved

Between 04/08 to 07/08, we experienced Issues for Billing preview for Confluence, Jira Work Management, Jira Service Management, Jira Software, and Jira Product Discovery. The issue has been resolved and the service is operating normally.

Users can now correctly browse their billing preview and take action
Posted 2 years ago. Aug 07, 2023 - 09:54 UTC

Investigating

We are investigating reports of Billing preview not being displayed for some products for some customers. We will provide more details once we identify the root cause.
Posted 2 years ago. Aug 07, 2023 - 06:14 UTC